VisualStudio.C++.C#2016. 4. 12. 11:25

 

개요

 

Visual C++ 2015 에서 신규 프로젝트 생성시에는 Windows XP 지원 코드 생성할 일 없기에 설치하지 않아도 되나, 과거버전에서 만들어진 프로젝트가 종속성을 갖고 있는 경우 "Windows XP Support C++" 설치 해야한다. 

 

상황 예.

VC++ 2015 에서 프로젝트 열려고 하면 아래처럼 솔루션 탐색기에서 사용할 수 없음 표시되고 있고 우마우스 클릭하면 "누락된 기능 설치" 를 실행할 수 있게 메뉴가 활성화 되어있다.

 

"누락된 기능 설치" 클릭하면 어떤 것에 종속성 있는지 보여주는데 "Windows XP support C++" 가 있어야 함을 보여주고 있다.

구체적으로 현재 열려고 하는 프로젝트에서 Windows 7.1 SDK 를 사용하고 있음을 보여주고 있다.

 

 

위 창에서 버튼 "설치" 클릭하여 설치하자.

 

 

 

 

 

설치. Windows XP Support for C++

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 본 글이 포함된 상위 정리 장소.

 Visual Studio/VC++/C/C# 활용정리 -> http://igotit.tistory.com/11

 

 

 

///736.

 

Posted by 리치굿맨

댓글을 달아 주세요