트레이딩/암호화폐2020. 11. 12. 17:59

 

개요. 

-api 에서 신규 기능이 추가된다고해도 이전 기능들은 유지해주는게 기 구현자들이 이미 개발해둔것 그대로 활용가능하여 유용한데.. 있던 기능이 하자가 없는것임에도 제거해버리는 경우가 자주는 아니지만 간혹 있다.  

- 번잡스럽긴 하지만,, 해당 정보는 메일로 보내주므로  사이트 뒤적거려 가면서 수시로 조사하지 않아도 됨은 다행이다만... 

- 폐기될 API 서비스가 도입된 프로그램이라면 반드시 신규 것으로 코드 수정해줘야함. 

 

2020.11 월 API 변경사항들. 

 

Thank you for trading with Bybit.

To enhance the efficiency and stability of the API endpoints, Bybit will upgrade our REST and WebSocket API on November 30, 2020. The following adjustments will be made:

1. The following WebSocket topics will be removed from service:

a) orderBook25 (please replace with topic orderBookL2_25 or

orderBook_200.100ms)

b) kline (please replace with topic klineV2)

c) instrument (please replace with topic instrument_info)


2. The following REST API will be upgraded. The older version of API will be deprecated on December 10, 2020. Effective immediately, the rate limit will be reduced by half before being completely removed from service on December 17, 2020. Hence, please use the following new REST API endpoints:

a) /open-api/order/list (please replace with /v2/private/order/list)

b) /open-api/stop-order/create (please replace with /v2/private/stop-order/create)

c) /open-api/stop-order/list (please replace with /v2/private/stop-order/list)

d) /open-api/stop-order/cancel (please replace with /v2/private/stop-order/cancel)

e) /open-api/order/replace (please replace with /v2/private/order/replace)

f) /open-api/stop-order/replace (please replace with /v2/private/stop-order/replace)

g) /open-api/order/create (please replace with /v2/private/order/create)

h) /open-api/order/cancel (please replace with /v2/private/order/cancel)

i) /position/list (please replace with /v2/private/position/list)

j) /user/leverage (please replace with /v2/private/position/list)


All updates can also be found here: 
https://bybit-exchange.github.io/docs/inverse/#2020-11-10


Please update your program promptly to enjoy uninterrupted trading activities. The latest version is required for SDK users. For Python SDK users, please kindly update to v0.2.10 or above. 


Thank you for your understanding and cooperation. If you have any questions, please contact us at 
IT@bybit.com.


The Bybit Team

 

Posted by 리치굿맨

댓글을 달아 주세요