본문 바로가기
트레이딩

MetaTrader5 module for Python. 설치

by 리치굿맨 2019. 4. 18.

MT5 module for Python 개요

Python 코드에서 메타트레이더 5(설치 상세) 프로그램과 통신하면서 가격 데이터를 가져와서 파이썬코드에서 활용할 수 있게 해주는 패키지.

 

 

MT5 module for Python 설치 

- 윈도우에서 아나콘다(설치 상세) 프롬프트 창에서 구문 pip install MetaTrader5 타이핑 

 

 


연관 정보

1. MT5 module for Python 사용법 상세 : https://igotit.tistory.com/2124

2. MT5 module for Python 사이트 : https://www.mql5.com/en/docs/integration/python_metatrader5

 

 

 

 

 


첫등록 : 2019년 4월 18일 

최종수정 : 

 

본 글 단축주소 : https://igotit.tistory.com/2112

 


 

댓글5

  • Favicon of https://yjst0702.tistory.com BlogIcon doodoo0702 2022.05.15 15:06 신고

    안녕하세요!! 혹시 현제 파이썬 3.10 버전에서도 적용이 되는걸까요?

    답글

    • Favicon of https://igotit.tistory.com BlogIcon 리치굿맨 2022.05.16 02:32 신고

      라이브러리 사이트에서의 설명은 파이썬 최신 버전 3.8 에서 사용하라고 되어있는데요..

      파이썬 3.1 포함 하위 버전 지원여부는 라이브러리 사이트에서는 명시적 설명이 없어 직접 해보는 방법 밖에 없습니다..

      pip install MetaTrader5 로 설치 하고 파이썬 3.1 에서 함수들 호출해봐서 정상 작동 하는지 직접 확인해봐야 합니다.

  • Favicon of https://yjst0702.tistory.com BlogIcon doodoo0702 2022.05.15 15:07 신고

    hello, I'm trying it on python 3.10 version.
    It it going to work?
    답글

  • Favicon of https://yjst0702.tistory.com BlogIcon doodoo0702 2022.05.18 18:24 신고

    이거는 윈도우 환경에서만 되는 건가요?
    맥에서는 작업이 안되는거 같아요
    답글

    • Favicon of https://igotit.tistory.com BlogIcon 리치굿맨 2022.05.18 18:39 신고

      네 본 라이브러리는 로컬 PC 에서 실행 중인 메타트레이더5 와 통신하는 방식입니다. 메타트레이더5는 윈도우 운영체제에서만 설치 및 실행가능하여 맥운영체제에서는 사용불가합니다.


   
현물 |선물 인버스 |선물 USDT     현물 | 선물 USDT |봇제작툴/카피트레이딩     현물 |선물 인버스 |선물 USDT     선물 인버스 |선물 USDT